WordPress 5.4対応かどうか、運営する複数サイトで調べてみた(プラグインとテーマ 2020/4/1)【追記あり】

2020年4月1日(日本時間)にWordPress5.4が配信されました。

プラグインとテーマを中心に、WordPress5.4対応かどうかを調べてみました。

当ブログはWordPressで作成していますが、他にも事務所サイトなど計4サイトで運用しているため、現在使用しているテーマ、プラグインとも様々です。

ご参考までにどうぞ!(最終更新:2020/6/12  WordPress 5.4.2対応確認済みです

 

WordPress5.4メモ:今回は導入されなかった機能

画像の遅延読み込み(Lazy-Loading)が機能として導入されるので、プラグイン等で実装している人は外したほうがいいよ、という話が今年になってちらほら出ておりましたが、今回は見送りになりました。

WordPress5.5(2020/8)では導入されるとのことなので、写真ブログなどで遅延読み込み用のプラグインを導入している方は対応を考えておかれたほうがいいと思います。私はLazy-Loading系のプラグインはすべて外しました。

WordPress5.4対応プラグイン(2020/4/1 18時現在)

実際に確かめたもののみ掲載しています。
プラグインはすべて2020/4/1現在の最新バージョンです。

  • Akismet Anti-Spam(バージョン 4.1.4)
  • All in One SEO Pack(バージョン 3.3.5)
  • AMP for WP – Accelerated Mobile Pages(バージョン 1.0.37)
  • Async JavaScript(バージョン 2.20.03.01)
  • Autoptimize(バージョン 2.6.2)
  • Blackhole for Bad Bots(バージョン 2.8)
  • Category Order and Taxonomy Terms Order(バージョン 1.5.7.1)
  • Classic Editor(バージョン 1.5)
  • Code Snippets(バージョン 2.14.0)
  • Coming Soon Page & Maintenance Mode by SeedProd(バージョン5.1.0)
  • Content Copy Protection & Prevent Image Save(バージョン 1.3)
  • Count Per Day(バージョン 3.6.1)
  • Edit Author Slug(バージョン 1.6.1)
  • Google XML Sitemaps(バージョン4.1.0)
  • Inline Related Posts(バージョン2.2.5)
  • Jetpack by WordPress.com(バージョン 8.3)
  • Optimize Database after Deleting Revisions(バージョン 4.8.8)
  • Photo Book Gallery(バージョン 7.5)
  • PS Auto Sitemap(バージョン 1.1.9)
  • Pz-LinkCard(バージョン 2.3.1)
  • reCAPTCHA Jetpack(バージョン 0.0.2)
  • Redirection(バージョン 4.7.1)
  • Search Regex(バージョン 1.4.16)
  • Social Media Flying Icons | Floating Social Media Icon(バージョン 4.3.4)
  • Speed Up – JavaScript To Footer(バージョン 1.0.7)
  • StopBadBots(バージョン 6.06)
  • Throws SPAM Away(バージョン 3.1.2)
  • WebSub/PubSubHubbub(バージョン 3.0.3)
  • WP Content Copy Protection with Color Design(バージョン 2.2.3)
  • WP Multibyte Patch(バージョン 2.8.4)
  • WP-DBManager(バージョン 2.80.3)
  • Wp-Insert(バージョン 2.4.7)

2020/4/30追記:上記プラグインはWordPress 5.4.1でも動作確認済みです(ただし4/30現在の最新バージョン使用)。

2020/6/12追記:上記プラグインはWordPress 5.4.2でも動作確認済みです(ただし6/11現在の最新バージョン使用)。

テーマのWordPress5.0~WordPress5.4対応【2020/4/1現在⇒2020/4/30現在⇒2020/6/11現在】

○=対応。実際に確かめたもののみ掲載しています。

Simplicity2(version 2.8.7.1 (2020/5/12))
WordPress5.4.1 ○WordPress5.4.2

Simplicity2(version 2.8.6.1 (2020/2/7))
WordPress5.4 ○WordPress5.4.1

Simplicity2(version 2.8.0 (2019/9/9))
○WordPress5.2.3  ○WordPress5.2.4 ○WordPress5.3
○WordPress5.3.1 ○WordPress5.3.2

Simplicity2(version 2.7.3)
○WordPress5.0.2 ○WordPress5.0.3 ○WordPress5.1
○WordPress5.2 ○WordPress5.2.1 ○WordPress5.2.2  ○WordPress5.2.3

 

STINGER PLUS2(version:20171207)
○WordPress5.0.3  ○WordPress5.1  ○WordPress5.2  ○WordPress5.2.1
○WordPress5.2.2  ○WordPress5.2.3 ○WordPress5.2.4 ○WordPress5.3
○WordPress5.3.1 ○WordPress5.3.2 ○WordPress5.4 ○WordPress5.4.1
WordPress5.4.2

 

First(version2.0.4,当ブログ使用テーマ)
○WordPress5.0.3() ○WordPress5.1(
○WordPress5.2  ○WordPress5.2.1 ○WordPress5.2.2  ○WordPress5.2.3
○WordPress5.2.4 ○WordPress5.3()○WordPress5.3.1 ○WordPress5.3.2 ○WordPress5.4( ○WordPress5.4.1 ○WordPress5.4.2

「データベースの更新が必要です」画面が出ましたが「更新」をクリックすれば無事にアップグレードできました。

FotoGraphy(version: 2.3.7(April 5, 2020))
WordPress5.4.1 ○WordPress5.4.2

FotoGraphy(version: 2.3.6)
○WordPress5.3.2 ○WordPress5.4 ○WordPress5.4.1

FotoGraphy(version: 2.3.3)
○WordPress5.3 ○WordPress5.3.1 ○WordPress5.3.2

FotoGraphy(version: 2.3.2)
○WordPress5.0.3  ○WordPress5.1 ○WordPress5.2  ○WordPress5.2.1
○WordPress5.2.2  ○WordPress5.2.3 ○WordPress5.2.4

WordPress5.4についてはこちらが詳しいです

WordPress 5.4 をチェックしています